PyOgre TextureShadow Help


19-10-2005 00:01:13

ok well as the subject states my texture shadows arnt quite workin right.
More specificly I need to turn off shadow casting for my ground plane(I think)
im using

its says that my entity has no such attribute.

what is the correct atribute then?


19-10-2005 00:06:41


Floor.castShadows = False

Also, since you're in Python you can do this:

for x in dir(Floor): print x

VERY useful feature. :)

Also, there's a thread here that has a guide on how to get PyOgre documentation (similiar to the real OGRE API).


19-10-2005 00:24:16

hey thx at lease it runs now. i wasnt typing False with a caps F
but that still wont make my shadows work

this is what it looks like

notic the crzy red and yello that is being made instead of a shadow

thx for the quick reply


19-10-2005 10:49:39

Try different shadow methods. Some seem to work differently depending on the choice of scene manager and other stuff.


19-10-2005 16:29:47

If I remember correctly, shadow enabled models also need extra information (specifically there must be normals calculated for it), but I'm having a hard time finding a place where sinbad has said this. You may try searching on the main forums to see if someone has had similar problems with this.

You also need to be sure you have set the far clipping plane out.