install instructions inaccurate?


17-07-2009 06:22:08

I'm trying to evaluate Python-OGRE against some commercial middleware, but I'm unable to install using the wiki directions.
I'm using Intrepid Ibex.
First I tried getting the binaries, and after adding the apt sources and updating I get:
E: Couldn't find package python-ogre
After wasting a half hour assuming I made a typo someplace, I decided to install from source. Everything stays sane until step 3.
greenland@dragonforge:~/development$ python python-ogre/ -r cmake gccxml boost cg scons freeimage zziplib pygccxml pyplusplus
Using the 2 cores
Traceback (most recent call last):
File "python-ogre/", line 9, in <module>
import environment
File "/home/greenland/development/python-ogre/", line 623, in <module>
class ogre(pymodule):
File "/home/greenland/development/python-ogre/", line 680, in ogre
libs = [boost.lib, 'OgreMain']
AttributeError: type object 'boost' has no attribute 'lib'

I thought maybe i needed libboost-python or something but It behaves the same either way.
I'm stumped. Any ideas?


19-07-2009 15:57:03

Decided to use the commercial product.


20-07-2009 15:30:48

I haven't tried building Python-Ogre on linux yet (seems waay too big of a hassle for now) but I'm curious; what commercial product did you choose ?


21-07-2009 02:27:53

Have you tried retrieving the packages one at a time or looking at the log file to find out where it got stuck exactly?

[EDIT] I've done it on Jaunty quite a few times. Gives me no problem. (*Although it doesn't run properly on jaunty 64 still compiles and builds alright. 8) )