[SOLVED] boost_python...dll not found. ??


10-12-2010 07:30:25

Alright - so Ive been slowly levelling up the skills with Ogre, but still very much a noob.

Im using Python 2.6

Ive had a few minor issues with getting my stuff working, but getting there slowly, solving most problems without major setbacks.
Until trying to create an exe.

Ive tried cx_freeze and py2exe. Ive had the most success so far with py2exe.

My issue after stuffing around with .dll files (dropped in msvcr90.dll, manifest, etc.)is now this:

Error: boost_python-vc90-mt-1_42.dll: No such file or directory

What on earth is this? :x

Ive attempted to acquire said dll file to no avail, thinking perhaps I can just drop this sucker in and it'll work... However little to no info exists regarding this thing. I got myself a copy of Boost 1.42, no dlls in that though. So - here I am, finally resorting to bugging the pro's :P

Help please :D

[ Alright - so I discovered the issue thanks to viewtopic.php?f=3&t=7611 <-- that topic. Not very well documented elsewhere, but ah well, now I know :)]


10-12-2010 13:47:21

you have to move every dependency in your project's folder then it should work


02-07-2013 22:29:59

I am experiencing exactly the same problem with python 2.6.4, so I've attempted to move on to python 2.7.5, but this gives the same response except for changing the last two characters of the dll file name from 42.dll to 45.dll. Lets hope someone understands whats going on.