DirectX Version for Prebuilt Binaries


16-12-2005 08:55:06

I downloaded PyOgre (1.06 and the media) and started thru the wiki tutorial.

I ran the first program in the tutorial, and got this:

After looking at the table on this webpage:

It looks like I should be using the August DX9 and that I have the June version installed (since I found a _26 version on my HD).

I'm guessing this will fix the problem, but I'm wondering if there's a "better" way to handle this?

Does this problem exist in normal OGRE and have I avoided it so far due to the fact I've been building everything from source before?


16-12-2005 14:29:03

I may be using a newer DX than the ogre maintainers are. You can do one of two things:

1) Update directX.
2) Comment out the directX plugin in pyogre's configuration. That is, open this file:

And comment this line out:

This will force pyogre to use the OpenGL renderer, which everyone should support.

Let me know if this doesn't fix the problem.


17-12-2005 01:30:21

I tried commenting out the DX9 plugin from the .cfg when I first hit the problem (using OpenGL only)...but for some reason, OpenGL doesn't work on that machine (haven't tried other machines yet). None of the 3D items showed up, only the debugging overlays. I wouldn't worry TOO much about the OpenGL not working *cough* ATI *cough* laptop driver *cough*. ;)

I did download the newer DX SDK and it did indeed work perfect :).

This is my first attempt at using Python, and so far I'm finding it to be an enjoyable experience. After going through the tutorial and reliving some childhood memories using the "turtle" package, I gave your tutorial a shot (only just starting it).

The tutorial for PyOgre on the wiki is awesome by the way, and I can't wait to play with it some more tonight. Keep up the good work!