Impossibility to run anything


02-03-2007 13:42:59

Hi guys,
I am a new user of pyogre and i have some problem with demos and apps...i have installed: media 0.90, demo_media 1.2, pyogre 0.90a for py24, and of course pyogre 1.06 for windows(binary)...also installed pyboost and psyco
I have tried to run simple tutorial apps and i get this error message:

..\src\OgreBillboardParticleRenderer.cpp(222): ogre error 4: Invalid billboard_type 'perpendicular_common'

I have tried to run the demo application for use of pygame with pyogre and i reiceve this message:

File "C:\Python24\Lib\site-packages\pyogre\", line 75, in ?
app = PyGameOGREApp()
File "C:\Python24\Lib\site-packages\pyogre\", line 13, in __init__
File "C:\Python24\Lib\site-packages\pyogre\", line 45, in _loadResources
ogre.ResourceGroupManager.getSingleton().addResourceLocation(path, key, section)
File "C:\Python24\Lib\site-packages\pyogre\", line 7294, in addResourceLocation
return _ogre.ResourceGroupManager_addResourceLocation(*args)
ExceptionPtr: ..\src\OgreZip.cpp(254): ogre error 9: ../media/packs/ - error whilst opening archive: Unable to read zip file.

I have resources.cfg and all the other .cfg files in the same directory of the file...

What should I do?I use win vista and i need some python 3d modules, if its impossible to use pyogre is there any other valid module?
Thank you!


02-03-2007 14:03:08

You could try using Python-Ogre instead of PyOgre as it's currently a little more active :)



02-03-2007 14:05:57

And it further reading your initial post it seems like you are mixing the 2 (Python-Ogre and PyOgre)..

Let me be specific in that they are 2 completely different Python wrappers for Ogre and shouldn't be mixed.


02-03-2007 17:18:36

I did it, i unisntall all the modules and cancelled all pyoge ois etcetc... folders
now i have downloaded the python-ogre for py24 and i have installed it( doing cmd> install)
as expected when i do import pyogre i get an error because i have deleted it,
now i can do import Ogre; result?
Warning (from warnings module):
File "C:\Python24\lib\site-packages\Ogre\", line 7
from _ogre_ import *
RuntimeWarning: to-Python converter for struct std::pair<class std::basic_string<char,struct std::char_traits<char>,class std::allocator<char> > const ,class std::basic_string<char,struct std::char_traits<char>,class std::allocator<char> > > already registered; second conversion method ignored.

But the module seems work, i can do from Ogre import * and i get no errors.
when i try to run an application(obviously i must replace all the pyogre and ogre with Ogre and replace the line
from pyogre import ogre with import Ogre) i reiceve this error:

Traceback (most recent call last):
File "C:\Python24\Lib\site-packages\pyogre\", line 75, in ?
app = PyGameOGREApp()
File "C:\Python24\Lib\site-packages\pyogre\", line 10, in __init__
File "C:\Python24\Lib\site-packages\pyogre\", line 20, in _initPyOgre
self.root = Ogre.Root("plugins.cfg")
RuntimeError: OGRE EXCEPTION(7:InternalErrorException): Could not load dynamic library .\RenderSystem_Direct3D9. System Error: The specified procedure could not be found.

in DynLib::load at \Development\Ocvs\ogrenew\OgreMain\src\OgreDynLib.cpp (line 80)

Do you know why??thank you


02-03-2007 21:19:02

What do you think this means: "RuntimeError: OGRE EXCEPTION(7:InternalErrorException): Could not load dynamic library .\RenderSystem_Direct3D9." The most important thing is to always read what the error message said. In this case it can't find the render system plugins so you plugins.cfg is wrong. You need to adjust it to point to the proper directory, it is contained inside the directy you unzipped Python-Ogre in.


03-03-2007 00:10:18

Also you might want to run the demos as shipped with Python-Ogre first, just to confirm that everything is fine before running your own code..

If you have older pyogre demos they will need some tweaking to convert (although it's not much)..