Problem running installer


06-02-2006 02:13:37

Hi, I'm very interested in giving pyOgre a try, but I'm having a little trouble with the first step: running the installer!

When I try to execute pyogre-, an error dialog pops up with the message
The application failed to initialize properly (0xc000007b). Click on OK to terminate the application

The same behavior happens with installer versions and, and also the installers for python 2.3.

I read somewhere that this might have something to do with the .NET runtime being corrupted. I've uninstalled and reinstalled both v1.1 and v2.0 of the .NET framework, and I still get the same error. Does the installer even use .NET?

The error is so impenetrable I don't even know where to begin to figure out its cause. Any suggestions? Am I missing some subtle prerequisite?

I'm running Windows XP, SP2.


08-02-2006 07:39:53

OK, so obviously this problem is really obscure and annoying, and is just a goof on my particular computer.

New question: I assume that the installer does little more than self-extract, so would someone be willing to package up the Windows binaries into a .zip file that I could just unzip and use? It would be much appreciated.


08-02-2006 15:14:15

It does a little more than self-extract, since it puts things in several directories (Python's site-packages directory, for instance). I'm not sure how trivial it would be to package it as a zip file or why it wasn't done that way to begin with. Maybe distutils could be used instead?

Seems also I heard somewhere that anything compiled with VC8 (as PyOgre is) requires the use of .msi files? It seems stupid, so maybe I'm mistaken about that.


08-02-2006 16:42:45

You could try to build pyogre yourself, it is not that hard.. Otherwise I think you only need site-packages/pyogre, so just unpack the installer and copy the files yourself. I have winrar on this machine, and it could open the .exe just fine, but for example 7-zip and others should also be able to do it.


08-02-2006 21:52:29

Awesome! Though 7-Zip wasn't able to extract the files from the exe, WinRAR was. That's really cool.