can't locate the 'plugins.cfg' file


07-05-2007 03:20:52

I just installed Python-Ogre with some trouble (at first rinning build claimed that the package directory isn't there, but then this error magically disappeared at some point), but none of the examples run, and all throw the same error: can't locate the 'plugins.cfg' file. The complete output is attached.
Any suggestions?
Edit: and yes, there is a plugins.cfg sitting in the directory

C:\Python25\lib\site-packages\ogre\renderer\OGRE\ RuntimeWarning:
to-Python converter for struct std::pair<class std::basic_string<char,struct std
::char_traits<char>,class std::allocator<char> > const ,class std::basic_string<
char,struct std::char_traits<char>,class std::allocator<char> > > already regist
ered; second conversion method ignored.
from _ogre_ import *
C:\Python25\lib\site-packages\ogre\io\OIS\ RuntimeWarning: to-Pyth
on converter for class std::multimap<class std::basic_string<char,struct std::ch
ar_traits<char>,class std::allocator<char> >,class std::basic_string<char,struct
std::char_traits<char>,class std::allocator<char> >,struct std::less<class std:
:basic_string<char,struct std::char_traits<char>,class std::allocator<char> > >,
class std::allocator<struct std::pair<class std::basic_string<char,struct std::c
har_traits<char>,class std::allocator<char> > const ,class std::basic_string<cha
r,struct std::char_traits<char>,class std::allocator<char> > > > > already regis
tered; second conversion method ignored.
from _ois_ import *
C:\Python25\lib\site-packages\ogre\io\OIS\ RuntimeWarning: to-Pyth
on converter for struct std::pair<class std::basic_string<char,struct std::char_
traits<char>,class std::allocator<char> > const ,class std::basic_string<char,st
ruct std::char_traits<char>,class std::allocator<char> > > already registered; s
econd conversion method ignored.
from _ois_ import *

** Warning: Unable to locate a suitable plugins.cfg file.
** Warning: Please check your ogre installation and copy a
** Warning: working plugins.cfg file to the current directory.

Traceback (most recent call last):
File "C:\Python25\PythonOgreRelease\demos\ogre\", line 33, in <m
File "C:\Python25\lib\site-packages\ogre\renderer\OGRE\", line 60, in
if not self._setUp():
File "C:\Python25\lib\site-packages\ogre\renderer\OGRE\", line 70, in
self.root = ogre.Root(getPluginPath())
File "C:\Python25\lib\site-packages\ogre\renderer\OGRE\", line 34, in
raise ogre.Exception(0, "can't locate the 'plugins.cfg' file", "")
AttributeError: 'module' object has no attribute 'Exception'



07-05-2007 07:36:03

You need to change into the same directory as the demo, and run it from there...

It looks for the plugin directory in the current working dir, which in your case is /python25/pythonogre....

If you get a moment perhaps you could add a trouble ticket to as we should probably enhance the framework to look in the script directory first..




07-05-2007 08:01:24

Just posting to say that things work. And started working with no apparent changes on my side. Running the py scripts directly threw that error, command line threw the same error, but as you said the working dir wasn't set. However now running the py scripts directly works just fine. Bizzare, but thanks =)