Close to an 1.0 RC2 release - check for issues.


05-06-2007 16:47:36

I'm getting close to building a 1.0RC2 build for windows users - and before I do thought I'd ask once more if anyone has any outstanding bugs/issues with the current RC1 release..

If you have a bug/issue can you please create a "new"ticket on the [b]Python-Ogre Site[/b].

Or you can respond to this message, or send an email to the gmail mailing list..

And for those interested here is the changelog since the 1.0RC1 release
  1. June xx 2007: Version 1.0 RC2(b) -- SnapShot
    * cleaned up demos and media files to match my working environment better
    * get/setUint32 added as utility functions
    * Demo_GetVerticies added into demo/ogre/tests dir to support extracting verticies and indicies from submeshes
    * Updated QuickGui to 0.9.4 (was SimpleGui)
    * CEGUI String.assign( xx ) now takes a python string (as xx) which can be utf8 encoded
    * fix in Py++ to expose correct class when there are multiple override options
    * GPU Parameter programming now possible -- see Demo_Compositor for code examples
    * CEGUI fixes for Window/MouseCursor/System/Renderering were missing an event subscription type
    * LOTS (?) of new functions exposed as we no longer filter protected non virtual functions from the generated source
    * added a Patch directory to the SVN to allow automated download and build of 3rd party libraries
    * removed OptimisedUtil and PlatformInformation from the Ogre master include list due to compile issues
    * lots of updates for the linux build (in the SVN)
    * as always, built against an updated Ogre 1.4 CVS

    May 13 2007: Version 1.0 RC2(a) -- SnapShot
    * Installer prompts to run dxwebsetup as people WILL need the latest DirectX drivers
    * Installer automatically runs vcredist_x86.exe for the shared C++ libraries neede for VC8
    * Build with latest CVS/SVN versions of supporting Libraries
    * Build with latest DirectX drivers (April 2007)
    * Included SimpleGUI
    * Exposed SharedPtr's for various ShadowCameras
    * Fixed to renderQueueStarted and renderQueueEnded (return True or False)
    * Further fixes to remove ugly function names (PixelUtil..)
    * changed return value policy on "clone" calls as we need to manage the object
    * switched to VC8 -- fingers crossed :)
    * getCustomAttributeUnsignedLong added and SF-OIS changed to use this for 64bit compatibility[/list:u]

    Many Thanks


06-06-2007 00:21:54

Sounds good! I've had no issues with python-ogre yet.


06-06-2007 12:57:08

woohoo, can't wait for the new release...

I tried to find the snapshots on the trac site, but can't seem to find them? Do you have to be registered on the trac site to download?


06-06-2007 13:39:26

Most recent snapshot is here

[edit] It's a couple of weeks old and aimed at Python 2.5.. [edit]



06-06-2007 16:08:09

What versions of python are supported by the PythonOgreInstaller1.0RC2a-SS1.exe installer?.

For a Python24 installation I had to replace boost_python-vc80-mt-1_35.dll with my own version. Also the .pyd/dll files are all dated 13 May 2007.

Running Dependency Walker shows _ogre_.pyd depends on Python24.DLL and boost_python-vc80-mt-1_35.dll but the installed version of boost_python-vc80-mt-1_35.dll depends on Python25.DLL ????.

Also isn't installed for the simplegui module and there appears to be a number of problems with the ogreode demos.


07-06-2007 01:06:44

Sorry I wasn't clear :(

The link I posted was the most recent snapshot (from a few weeks ago). and as it's a snapshot it doesn't get the same care and attention that a real release gets... And I tend to only test it with Python 2.5 (although I do build it with both versions, however I obviously screwed up the boost versions)..

The next release will be a "real release" not a snapshot :)



08-06-2007 02:42:30

I'm using RC1. And here's a wee problem I just found this morning. But I think it's too trivial to delay an immensely anticipated RC2. It may have been fixed anyway.

when I created a particle with particleSystem = sceneManager.createParticleSystem("nasal_blood", "myParticles"), and then try to get the script name by calling particleSystem.getOrigin() it returns empyt string. Ya.

Otherwise congrats on the progress and good day.


08-06-2007 03:04:05

I am using RC1 on WinXP with an ATI x850. I have not had problems running under OpenGL, but I just tried to run some demos using D3D and my window freezes at this console line.

Parsing scripts for resource group General
Parsing script Examples.program

I have had no problems running apps from the OgreSDK or the Python-Ogre TechDemo using D3D.


08-06-2007 03:09:00

Did you "recently" download the RC1 or is this an original version ??

You need to be using RC1(c) as I shipped the earlier versions with some media files from an earlier version of Ogre that turned out to be incompatible with some ATI cards..

As a quick fix simply delete the files in media/materials/programs and replace them with those in the Ogre SDK release




08-06-2007 03:26:41

Oh, I'm sorry. I just checked the changelog and I am using RC2.

April 15 2007: Version 1.0 RC2 Release
Turned out that there were some old media files in the release so I've decided to quickly put out a snapshot
release .
* removed old media from media/materials/programs - caused ATI graphics cards to crash
* fixed wrappers for Node.getChild/removeChild etc as I'd incorrectly wrapped them :(
* added build date and time to module doc ie. print ogre._ogre_.__doc__

I also replaced the media folder with the one from the OgreSDK and I am still freezing at that same line in the console. I wish I knew how do debug this better, but I am only a novice at this. I will try the latest snapshot RC2(b).


08-06-2007 03:31:44

Go ahead and delete the media/material/programs and see if it fixes the issue -- it may be that I didn't actually fix it correctly previously ??


08-06-2007 03:39:31

If I remove from the resources.cfg this line I can run demos in D3D.


I'll try to narrow down the exact file causing the problem next.


08-06-2007 03:45:39

It is that is causing the problem. Should I log it as a bug?


08-06-2007 04:07:34

Can you give me the date and size on the file..

The one I'm going to use in the next release is dated 5/29 and is 7946 in size..

If you copy the verison from your Ogre SDK does it work?



08-06-2007 04:43:21

The one I am having problems with is dated February 20, 2007 and is 7,946 bytes. I have tried using the media folder from the 1.4.0 SDK for Code::Blocks + MinGW, but that same file causes the issue.

It is very strange, because no D3D problems from the OgreSDK, but D3D problems from Python-Ogre, even when I use the same file for both.

I just tested the 1.0RC2a snapshot and encounter the same D3D problem with the installed as well as the one distributed with OgreSDK 1.4.0 for CodeBlocks/MinGW and the one included in Shoggoth CVS.


09-06-2007 19:06:51

I had the same problem with my AGP FX5200 128MB card in my old computer (and fixed it the same way). When I upgraded to a PCI-E X1950 Pro 256MB the problem went away.