autocompletition in eclipse [solved]


31-07-2007 09:50:05


I installed the python-ogre binaries. It works quite well. As IDE I use eclipse with PyDev. After including the packages and copying the libs to /usr/lib I can run the examples by hitting run. So far everything ok. Auto-completition works very well for all libs (arbitrary other ones) but python-ogre. I can import the package and it even gives me drop down lists after "ogre." and "ogre.renderer.".
However, in the code the only proposals in the auto-completition list are the members that are already used in the file (which is almost nothing). Some days ago a managed to get the whole list by typing "ogre._ogre_.". But that's not correct code than. Right now I can't even get that one working.
  1. Does anybody know how to get correct auto completition in eclipse with PyDev?[/*:m]
  2. Does anybody know how to get the libs in the right place without copying them to /usr/lib? (Like an equivalent for exporting LD_LIBRARY_PATH in a console.)[/*:m]
  3. Is there a need for a little eclipse tutorial after these points have been solved? It is quite trivial to set up a project with eclipse.[/*:m][/list:o]



31-07-2007 21:19:11

I don't know how to tweak the setting through eclipse, but what I do is just run eclipse from a shell with the environment setup properly. Then it can run the python-ogre programs just fine. I do not seem have any problems with auto-completion. My guess is once you fix this issue everything will sort its self out.


31-07-2007 23:59:57

Thanks, Game_Ender!

It works. I wrote a little script to the the LD_LIBRARY_PATH and start eclipse subsequently. One question remains: Why? The program ran before like it does now. Why the weird auto-completition?