Some demos not working on linux :(


02-02-2008 21:45:44

Hey all

Just got done building from source and also building the package and have had some success running the demos in ~/development/python-ogre/demos/ogre but only after modifying the plugins.cfg file to be like the one in step 4 of the build guide. Why or how this works I do not know, so correct me if I'm wrong but that's what worked :P.

I noticed something in the instructions that wasn't quite right. For instance the end of step 4 leaves you in ~/development/ogrenew/Samples/Common/bin, while the beginning of step 5 expects you to be in ~/development... now this could be some kind of idiot test (that I passed!) but I don't think it makes for a smooth build process :P.

Overall though the build process seemed very thought out, kudos to Andy :)

Now the problem is that when I run some of the demos they fail, like so:

abuser-desktop% pwd
abuser-desktop% python
Traceback (most recent call last):
File "", line 17, in <module>
import ogre.gui.CEGUI as CEGUI
File "/home/abuser/development/root/usr/lib/python2.5/site-packages/ogre/gui/CEGUI/", line 9, in <module>
from _cegui_ import *
ImportError: No module named _cegui_

I also built all the mentioned modules, hoping maybe one of them might fix it. They seemed to build ok, with maybe the exception of ode, but that didn't seem to fix the problem. I also tried running the demos in ~/development/python-ogre/demos/ogreode and came up with a similar error:

abuser-desktop% pwd
abuser-desktop% python
Traceback (most recent call last):
File "", line 10, in <module>
from SimpleScenes import *
File "/home/abuser/development/python-ogre/demos/ogreode/", line 6, in <module>
import ogre.renderer.OGRE as ogre
ImportError: No module named ogre.renderer.OGRE

This happened even after I adjusted the plugin.cfg in that directory to look like the other one:

# Defines plugins to load

# Define plugin folder

# Define D3D rendering implementation plugin


03-02-2008 08:55:48

I updated the install note on Step4/5 to change back to the development directory :)

When you built the additional modules did you remember to install them afterwards.. Make sure you do a:
python python-ogre/ -b install
Also the OgreOde demo must be run as
the "" files are imported by the master demo program.



03-02-2008 16:59:38

Hmm did the install bit.. I still get this error, even when I run

abuser-desktop% pwd
abuser-desktop% python
Traceback (most recent call last):
File "", line 14, in <module>
import ogre.renderer.OGRE as ogre
File "/home/abuser/development/root/usr/lib/python2.5/site-packages/ogre/renderer/OGRE/", line 10, in <module>
from _ogre_ import *
ImportError: cannot open shared object file: No such file or directory

Now.. I know I have ogre installed, because I can run the other demos. Why would it not be finding it? Being newish to python I had a look at, as suggested and just kinda glazed over :(. Could you describe were modules are located and maybe I could manually iimport/copy/move them? I just want it to work :P.


11-03-2008 17:19:58

Sorry for necro-posting, just getting some time to work on this again :P

I guess the real problem is that I don't know where even regular libraries are stored, much less these. I'm not very experienced when it comes to using python :( Could this be explained to me?

Maybe if I used the binaries I could get something to work.


14-03-2008 15:46:35

Seems to have worked :D Sorry for filling up the forum w/ my useless chatter.