EXE on windows XP error (no py2exe problem)


09-03-2009 00:35:55

i'm not a newbee in a pyogre and I develope on wndows XP.
On my pc my exe (build using py2exe) works.
On pc of my friends (a graphic artist) doesn't work..
his error on app.exe.log file (where app is application name):
(importing _ogre_.pyd)
ImportError: DLL load failed: The application could not be initiated because its configuration is incorrect. Reinstalar the application can solve the problem.

my friend's system has all dll needed.
he use xp professional 32bit.
he had run dxwebsetup.exe and vcredist_x86.exe.. but problem's still alive..

any idea?
many thanks in advance guys ;)


09-03-2009 00:37:47

i'm using pyOgre Release 1.6.1


09-03-2009 21:21:22

here's complete Exception:

Traceback (most recent call last):
File "_single_obj.py", line 16, in <module>
File "ogre\renderer\OGRE\__init__.pyc", line 10, in <module>
File "ogre\renderer\OGRE\_ogre_.pyc", line 12, in <module>
File "ogre\renderer\OGRE\_ogre_.pyc", line 10, in __load
ImportError: DLL load failed: Impossibile avviare l'applicazione specificata. La configurazione dell'applicazione non รจ corretta. Una nuova installazione dell'applicazione potrebbe risolvere il problema.

my friend use two nvidia 8800GTS 512MB in SLI
maybe a graphics hardware compatibility?

any idea?!?!?!?! :(


12-03-2009 12:05:39

have you tried copying ALL dlls into the same folder as the exe? I know its not very elegant, but for now it might be the only solution until someone figures out the py2exe python-ogre thing properly. By the DLLs I mean the contents of the plugins folder, and also all dlls in C:\Python25\Lib\site-packages\ogre as well.

Another option would be to try freezepython ( google it ), but previous experience says that is actually harder than py2exe ( at least for python-ogre ).

If you have any success please let us all know :) Its definitely possible to sort this out as people have done so before, but its a bit of black art.


15-03-2009 21:43:10

I wrote a batch file to pack up MV3D, py2exe it, and build the NSIS installer. You can see the file here:


Hope that helps. It does do some moving around of modules after py2exe. This is just because I use dynamic imports and py2exe isn't picking up all the files it needs, so you can probably ignore that.




27-03-2009 14:06:37

Copying ALL dlls into the same folder as the exe WORKS! yes, its not very elegant but IT WORKS!
thanks a lot guys!

(and i'm sorry for delayed replay.. i've been busy.. )



28-03-2009 00:03:52

No worries. Glad you got it working!



29-03-2009 02:41:05

Hey, I'm having an absolute nightmare building and distributing my application. Supposedly my users are getting the same error, and I've included all the needed DLLs already. It works perfectly on my Vista machine, on my virtual XP box, and at work on my XP box there. I have no clue anymore why anyone is having issues.

You can download my build here: http://willhostforfood.com/access.php?fileid=60232
You can see the various people who can't manage to run the builds in this thread: http://forums.tigsource.com/index.php?topic=4870.75

I haven't used the MV3D .bat verbatim, but I've done the same DLL moving it's done. I haven't actually run "setup.py install" to install Python-Ogre into my python site-packages, so I'm going to try that next.


29-03-2009 03:18:57

The first error mentioned in that thread looks unrelated to installation-- seems like a messed up overlay? After that, the problems were less clear. I'd ask people who are having issues what error messages specifically they are getting. If ogre is making an Ogre.log, that would be helpful to see as well. I put all the .pyd's into the same directory as the app along with all the .dll's. The NSIS installer I made auto installs the VC++ redist exe as well. Maybe that last part is the problem? That could cause it to work for some people and not others since some people may already have the VC++ stuff installed.



29-03-2009 03:25:51

Btw, it worked fine for me (and of course I have the VC redistributable installed). Looks like a pretty cool game! :)


29-03-2009 17:59:08

Hey, thanks for the help. It was the VC Redistributable.

For some reason I forgot about that when trying out various fixes. It's just another one of those little details, so obvious in retrospect, that you slap yourself for not thinking about it!